You must use the version that is compatibe with your version of ios. Our icon packs are kept updated for the newest version of ios. We recommend that you always keep your device on the newest Jailbroken version of ios.

Take your phone to the next level!